29. 10.

64位的系统给php添加curl的时候,
cd /usr/local/src/php-5.2.6/ext/curl/
/usr/local/php-fcgi/bin/phpize
./configure –with-php-config=/usr/local/php-fcgi/bin/php-config
居然出现一下错误!
checking for gnutls support in libcurl… no
checking for curl_easy_perform in -lcurl… no
configure: error: There is something wrong. Please check config.log for more information.

我赶紧检查有没有装curl的devel
rpm -qa |grep curl

全都有!
查了半天资料, 还是找到结果了, 只要以下包都安装了, 就可以完美通过!
curl-devel-7.15.5-2.el5
e2fsprogs-devel-1.39-15.el5
krb5-devel-1.6.1-25.el5
libidn-devel-0.6.5-1.1
openssl-devel-0.9.8b-10.el5
至于每个包的作用, 自己去查吧! 呵呵


作者: hao32 | 可以转载, 转载时务必以超链接形式标明文章原始出处和作者信息及版权声明
网址:https://www.hao32.com/webserver/264.html

Tags: , ,

有一条对 „解决checking for gnutls support in libcurl… no“ 的评论

  1. 蔡朝海 发表评论说:

    大哥,你给的那些包,到哪里去下载啊?请求告之,谢谢!可以发到我的邮箱吗?谢谢

发表评论: